using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?![J|S|V])\w*\b|\W*";
string input = @"['Senior' 'Jeune,Vét,Senior' 'Senior et Vétéran' 'Vétéran' 'Jeune'
'Jeune et Vétéran' 'Jeune et Senior']";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}