re = / (.*) \(.*\[(.*)\]/
str = 'By Patrick Traughber (@ptraughber), Product Manager [06:04 UTC]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end