using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]+[\.a-z0-9]{2,}\@[a-z0-9]{2,}\.[a-z\.]{2,}$";
string input = @"hunganh020301@gmail.com
hung.anh020301@yahoo.com.vn
hunganh@tes.microsoft.com
hunganh 213@gmai l. com
23sneaker.store@shop.vn
h.a.anh @gmail.com
hung. anh
hung .anh
hun.2.3.123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}