use strict;
my $str = 'http://some_domain.com/some_link/';
my $regex = qr/(http)(:[^\s]+)/mp;
my $subst = '$1s$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";