re = /(http)(:[^\s]+)/m
str = 'http://some_domain.com/some_link/'
subst = '$1s$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result