import Foundation
let pattern = #"(http)(:[^\s]+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"http://some_domain.com/some_link/"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1s$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)