#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[1-9]\d{0,3} ?[a-zA-Z]?(?: ?[/-] ?[1-9]\d{0,3} ?[a-zA-Z]?)?$"
Local $sString = "############# valid ##########" & @CRLF & _
"12" & @CRLF & _
"12a" & @CRLF & _
"12A" & @CRLF & _
"12 A" & @CRLF & _
"12 a" & @CRLF & _
"12 b" & @CRLF & _
"12 z" & @CRLF & _
"121 b" & @CRLF & _
"56/58" & @CRLF & _
"56/58a" & @CRLF & _
"56-58" & @CRLF & _
"56 - 58" & @CRLF & _
"56-58a" & @CRLF & _
"1234" & @CRLF & _
"1234 a" & @CRLF & _
"" & @CRLF & _
"56/58a" & @CRLF & _
"18a - 19b" & @CRLF & _
"18a-19b" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"############# not valid ##########" & @CRLF & _
"12345" & @CRLF & _
"25-ab" & @CRLF & _
"12ü" & @CRLF & _
"12_" & @CRLF & _
"asdfghjklöqwertzuioyxcvbnm" & @CRLF & _
"12!"§$$%&/()" & @CRLF & _
"a2" & @CRLF & _
" a2" & @CRLF & _
"13àâäèéêë" & @CRLF & _
"0" & @CRLF & _
"123aaa123, " & @CRLF & _
"123 aaa 123 " & @CRLF & _
"1 a 1 " & @CRLF & _
"1a 1' " & @CRLF & _
"1a1 " & @CRLF & _
"13àâäèéêë" & @CRLF & _
"00 a" & @CRLF & _
"a a" & @CRLF & _
"00a" & @CRLF & _
"0a" & @CRLF & _
"12 ab 12"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")