using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<p[^>]*>)(.*?)(<\/p>)|(<p[^>]*>)";
string input = @"one <p>two</p> three <p class=""test"">four</p> five <a>six</a> seven <p> eight nine <p/> ten";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}