package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(<p[^>]*>)(.*?)(<\/p>)|(<p[^>]*>)`)
var str = `one <p>two</p> three <p class="test">four</p> five <a>six</a> seven <p> eight nine <p/> ten`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}