#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)^(?:lundi|mardi|mercredi|jeudi|vendredi|samedi|dimanche) [0-3]?[0-9] (?:janvier|f[eé]vrier|mars|avril|mai|juin|juillet|ao[uû]t|septembre|octobre|novembre|d[eé]cembre) [0-9]{4} [0-9]{1,2}:[0-9]{1,2}:[0-9]{1,2}$"
Local $sString = "Jeudi 3 avril 2014 16:23:00"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")