import re
regex = re.compile(r"(\d{3},)(\d{3})(.+?)(([a-zA-Z]{3},)([a-zA-Z]{3}).+)", flags=re.DOTALL)
test_str = ("123,234,345,456,567\n"
"abc,bcd,cde,def.")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")