using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[+-]?\d+(?:,\d{3})*(?:\.\d+)?\b";
string input = @"hello-sdvf-1,234.23 23 everybody 4";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}