package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[+-]?\d+(?:,\d{3})*(?:\.\d+)?\b`)
var str = `hello-sdvf-1,234.23 23 everybody 4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}