re = /^(?:.*?\/)(.+)$/m
str = 'circuit/asie/indonesie/denpasar-bali/
circuit/asie/indonesie/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end