using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"- v\d+$";
string input = @"hello world - v2
hello world - v88
hello world
hello world - v";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}