re = /- v\d+$/m
str = 'hello world - v2
hello world - v88
hello world
hello world - v'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end