$re = '/[T]\d{7}/';
$str = 'Re: MESSAGE - OPEN: 12329/T1001246';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);