re = /^(?=.*?[A-Z])(?=.*?[a-z])(?!.*?[=?<>()'"\/\&]).{8,20}$/m
str = 'Abscedsd
Ancbdj123
asjkQs23
asdfghjk
Asdfghj&
ashhgWhd=?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end