const regex = new RegExp('^-?[1-9]*(?!0000)[0-9]{4}-(?:0[0-9]|1[0-2])-(?:0[1-9]|[1-2][0-9]|3[0-1])T(?:(?:[0-1][0-9]|2[0-3]):(?:[0-5][0-9]):(?:[0-5][0-9])(?:\\.[0-9]*[1-9]+)?|24:00:00)(?:(?:\\+|-)(?:(?:0[1-9]|1[0-3]):[0-5][0-9]|14:00)|Z)?', '')
const str = `2015-12-31T23:00:00.34-13:33`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}