$re = '/^-?[1-9]*(?!0000)[0-9]{4}-(?:0[0-9]|1[0-2])-(?:0[1-9]|[1-2][0-9]|3[0-1])T(?:(?:[0-1][0-9]|2[0-3]):(?:[0-5][0-9]):(?:[0-5][0-9])(?:\.[0-9]*[1-9]+)?|24:00:00)(?:(?:\+|-)(?:(?:0[1-9]|1[0-3]):[0-5][0-9]|14:00)|Z)?/';
$str = '2015-12-31T23:00:00.34-13:33';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);