$re = '/(?<=Id="{)(?!<#).*(?=})/m';
$str = 'Id="{fbc4796c-e6f9-463b-8fda-081d8c20d19d}
Id="{<#=Guid.NewGuid()#>}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);