import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<p value=\"id\">(?=1445).+\\R.+<p value=\"IP\">)(\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3})(.+)";
final String string = " <list name=\"ItemList\">\n"
+ " <item>\n"
+ " <p value=\"id\">1445</p>\n"
+ " <p value=\"IP\">10.25.30.19</p>\n"
+ " <p value=\"Prflen\">26</p>\n"
+ " </item>\n"
+ " <list name=\"ItemList\">\n"
+ " <item>\n"
+ " <p value=\"id\">1499</p>\n"
+ " <p value=\"IP\">10.40.50.53</p>\n"
+ " <p value=\"Prflen\">26</p>\n"
+ " </item>\n"
+ " <list name=\"ItemList\">\n"
+ " <item>\n"
+ " <p value=\"id\">1445</p>\n"
+ " <p value=\"IP\">10.45.70.19</p>\n"
+ " <p value=\"Prflen\">26</p>\n"
+ " </item>\n"
+ " <list name=\"ItemList\">\n"
+ " <item>\n"
+ " <p value=\"id\">1446</p>\n"
+ " <p value=\"IP\">10.77.90.55</p>\n"
+ " <p value=\"Prflen\">26</p>\n"
+ " </item>";
final String subst = "\\110.25.30.19\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}