use strict;
my $str = '<h1 class=\'\' id=\'\' title=\'\'></h1>';
my $regex = qr/(\w+='')\ /p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";