package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(?:(?:\s?\(?)*([a-z-]+\s?[a-z-]+)(?:\)\s)*)`)
var str = `★ Gut Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Safari Mesh (Field-Tested)
★ Gut Knife
★ StatTrak™ Gut Knife | Forest DDPAT (Field-Tested)
★ StatTrak™ Falchion Knife | Safari Mesh (Field-Tested)
★ Falchion Knife | Night (Field-Tested)
Falchion Knife | Night (Field-Tested)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}