using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[{]%\s*?\b([^}]*start[^}]*)\b\s*?%[}]\s*?\b(.*?)\b\s*?[{]%\s*\b([^}]*end[^}]*)\b\s*%[}]";
string input = @"{% start %}some random text{% end %}";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}