re = /(?=^sudo:x:\d+:.*$)(.*):/m
str = 'sudo:x:27:foo,bar,baz
nosudo:x:27:foo,bar,baz'
subst = '\\1<mychar>'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result