re = /^(([0]?[1-9]|1[0-2])\/([0-2]?[0-9]|3[0-1])\/[1-2]\d{3}) (20|21|22|23|[0-1]?\d{1}):([0-5]?\d{1}):([0-5]?\d{1})$/
str = '12/12/2006 00:00:00'
# Print the match result
str.match(re) do |match|
puts match.to_s
end