re = /(.*?)(\s*\(.*?\))/m
str = 'Javascript (12+ years), Java (10 years)'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result