package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(:#).*`)
var str = `grep: ./lib/ignite-core-2.10.0.jar: binary file matches
./log4j.properties.template:#log4j.appender.FILE=org.apache.log4j.RollingFileAppender
./log4j.properties.template:#log4j.appender.FILE.MaxFileSize=20MB
./log4j.properties.template:#log4j.appender.FILE.MaxBackupIndex=0
./log4j.properties.template:# log4j.appender.FILE.MaxBackupIndex=2
./log4j.properties.template:log4j.appender.FILE=org.apache.log4j.DailyRollingFileAppender
./log4j.properties.template:log4j.appender.FILE.datePattern='.'yyyy-MM-dd
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}