use strict;
my $str = 'grep: ./lib/ignite-core-2.10.0.jar: binary file matches
./log4j.properties.template:#log4j.appender.FILE=org.apache.log4j.RollingFileAppender
./log4j.properties.template:#log4j.appender.FILE.MaxFileSize=20MB
./log4j.properties.template:#log4j.appender.FILE.MaxBackupIndex=0
./log4j.properties.template:# log4j.appender.FILE.MaxBackupIndex=2
./log4j.properties.template:log4j.appender.FILE=org.apache.log4j.DailyRollingFileAppender
./log4j.properties.template:log4j.appender.FILE.datePattern=\'.\'yyyy-MM-dd
';
my $regex = qr/(:#).*/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}