using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:^|(\w)(?!\1))(([A-Z])\3{3})(?!\3)";
string input = @"3346AAAA44
3973BBBBBB44
9755BBBBBBAAAA44
AAAAB
AAAA
BAAAA
AAAAA";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}