$re = '/(?:^|(\w)(?!\1))(([A-Z])\3{3})(?!\3)/m';
$str = '3346AAAA44
3973BBBBBB44
9755BBBBBBAAAA44
AAAAB
AAAA
BAAAA
AAAAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);