$re = '/(\d+(?:\s*\w\b)?)[^\d]+\d{5}[^\d]+$/m';
$str = '32 Rue Jean Jaures 69000 Lyon
Bâtiment 1 32 Rue Jean Jaures 69000 Lyon
32 B Jean Jaures 69000 Lyon
Bâtiment 1 32 B Rue Jean Jaures 69000 Lyon';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);