using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})+";
string input = @"""badips"":[""123.456.789.12"",""123.456.789.13"",""123.456.789.14""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}