$re = '/(\d{1,3}\.\d{1,3}\.\d{1,3}\.\d{1,3})+/m';
$str = '"badips":["123.456.789.12","123.456.789.13","123.456.789.14"]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);