re = /\babc(?![^<]*>)/
str = 'abcdef abc<span abc>defabc abcdef</span> abc defabc'
subst = 'xxx'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result