import Foundation
let pattern = #"\babc(?![^<]*>)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"abcdef abc<span abc>defabc abcdef</span> abc defabc"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"xxx"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)