const regex = /([\w.-]+)(\/[\w.-]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([\\w.-]+)(\\\/[\\w.-]+)$', 'gm')
const str = `res/icons/android/quickshop/icon-36-ldpi.png
res/icons/android/quickshop/icon-48-mdpi.png
res/icons/ios/quickshop/icon-72-hdpi.png
res/icons/ios/quickshop/icon-96-xhdpi.png`;
const subst = `homecenter$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);