Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?<=[^0-9][^0-9]\s)(?P<val>[1-9]|[1-2][0-9]|3[0-3])(?=\s[^a-z\s]+\s[^a-z\s]+\s[^a-z\s]+$)
"
gm
Input 1
1
New
Increase)/Decrease in inventories -6,999,009 3,784,581 Increase)/Decrease in receivables -7,393,450 3,842,984 Increase/(Decrease) in payables 5,821,857 -18,006,883 Grant received 0 625,255 Interest paid -565,584 -1,495,877 Tax paid -22,168 -21,694 The annexed NOTEs form an integral part of the financial statements. 36 Annual Report 2012 Pentamaster Corporation Berhad (5723070 ) www.pentamaster.com CONSOLIDATED STATEMENT OF CASH FLOWS FOR THE YEAR ENDED 31 DECEMBER 2012 (CONT'D) 2012 2011 RM RM CFI Dividend income 80,863 81,078 Interest received 67,568 316,523 Proceeds from disposal of property, plant and equipment/non current assets held for sale 27 28,000 48,298,000 Purchase of property, plant and equipment 27 -64,624 0 CFF Short term borrowings obtained/(repaid) 6,367,671 -4,757,230 Net term loans repaid -3,382,414 -40,376,659 Net Cash Flow -838,456 -168,122 Cash and cash equivalents brought forward 5,939,258 6,147,628 FOREIGN CURRENCY EXCHANGE DIFFERENCES ON OPENING BALANCE 35 -40,248 Cash and cash equivalents carried forward 5,100,837 5,939,258 RM RM CFO Loss)/Profit before taxation -2,083,184 2,145,073 Adjustments for :0 Amortisation of intangible assets 2,689,572 4,087,413 Bad debts written off 7,594 0 Deferred income released -1,854,722 -3,786,856 Depreciation 2,855,169 2,941,851