package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w{2}-\d{2}-\d{2})|(\d{2}-\d{2}-\w{2})|(\d{2}-\w{2}-\d{2})|(\w{2}-\d{2}-\w{2})|(\w{2}-\w{2}-\d{2})|(\d{2}-\w{2}-\w{2})|(\d{2}-\w{3}-\d{1})|(\d{1}-\w{3}-\d{2})|(\w{2}-\d{3}-\w{1})|(\w{1}-\d{3}-\w{2})|(\w{3}-\d{2}-\w{1})|(\d{1}-\w{2}-\d{3})`)
var str = `XX-99-99
99-99-XX
99-XX-99
XX-99-XX
XX-XX-99
99-XX-XX
99-XXX-9
9-XXX-99
XX-999-X
X-999-XX
XXX-99-X
9-XX-999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}