import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w{2}-\\d{2}-\\d{2})|(\\d{2}-\\d{2}-\\w{2})|(\\d{2}-\\w{2}-\\d{2})|(\\w{2}-\\d{2}-\\w{2})|(\\w{2}-\\w{2}-\\d{2})|(\\d{2}-\\w{2}-\\w{2})|(\\d{2}-\\w{3}-\\d{1})|(\\d{1}-\\w{3}-\\d{2})|(\\w{2}-\\d{3}-\\w{1})|(\\w{1}-\\d{3}-\\w{2})|(\\w{3}-\\d{2}-\\w{1})|(\\d{1}-\\w{2}-\\d{3})";
final String string = "XX-99-99\n"
+ "99-99-XX\n"
+ "99-XX-99\n"
+ "XX-99-XX\n"
+ "XX-XX-99\n"
+ "99-XX-XX\n"
+ "99-XXX-9\n"
+ "9-XXX-99\n"
+ "XX-999-X\n"
+ "X-999-XX\n"
+ "XXX-99-X\n"
+ "9-XX-999";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}