import re
regex = re.compile(r"(\d{3})@.*?@(\d{3})-(\d{3})-(\d{4})\s+(\d{2}:\d{2}:\d{2})\s(\d{8})@(.*?)@(.*?)([WV].{3})@(.*?)@(.*?)LEC\s(.*?)@(.{29})([A-Z]{2})@(.*?)@.*?ESN(.*?)@P#(.{12}).*?ALT#(\d{3})-(\d{3})-(\d{4})@X(.{11}).*?Y(.{11})(.*?)@(.*?)@(.*?)@(.*?)(.*?)@(.*?)@")
test_str = ("_201@ @815-440-0499 14:12:30 01162018@VERIZON @936A WPH2@STONY POINT RD @ LEC VERIZ@DIXON IL@W SECTOR @ ESN 199@P#815-440-0499 ALT#815-511-7655@X-089.482548 Y+041.840840 CF90 @UNC00025 Z ZUNC @WIRELESS 911 CALL @WIRELESS 911 CALL @WIRELESS 911 CALL @_\n\n"
"204@ @319-430-1670 11:28:30 01162018@VERIZON WIRELESS @ WPH1@LINCOLN HWY @ LEC VERIZ@DIXON IL@NE SECTOR @ ESN 199@P#319-430-1670 ALT#815-511-7657@X-089.488534 Y+041.837557 CF0 @UNC00000 Z ZUNC @WIRELESS 911 CALL @WIRELESS 911 CALL @WIRELESS 911 CALL @_\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")