import re
regex = re.compile(r"(?<![\w$])$([\w$]+(?:[.!][\w$]+)*)")
test_str = ("Hey $mark\n"
"Hey $mark.\n"
"Hey $mark, you're nice\n"
"Hey $mark!!!! I didn't think of that,\n"
"foo foo foo foo @mark_markus@gmail.com\n"
"foo@dontmatchthis\n"
"blah @mark.markus blah\n"
"blah blah @mark@gmail.com\n"
"@jozko\n"
"@mark ahoj\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")