import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"\"*[^\"]*\"*\"";
final String string = "If cmd = \"History Report\" Then\n"
+ " Range(\"D2\").Formula = \"=TEXT(\"\"\" & createDate & \"\"\",\"\"\" & Replace(subtitleFormat, \"\"\"\", \"\"\"\"\"\") & \"\"\")\"\n"
+ " comment = \"This task is completed!\"\n"
+ "End If";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}