import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^| )@[^@\\s]+(?!.*?\\s@\\w+.*$)";
final String string = "hello hi @why helo @blow but @name\n\n"
+ "hello hi @why helo @blow but name@name\n\n"
+ "@blow but not know how to resolve this";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}