const regex = /^[a-zA-Z\u0600-\u06FF,-][\sa-zA-Z\u0600-\u06FF,-]*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[a-zA-Z\\u0600-\\u06FF,-][\\sa-zA-Z\\u0600-\\u06FF,-]*$', '')
const str = `هل بعتم بيتكم في نيويورك`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}