using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^\s(]|\s[^\s(])[^()\s]*(?=\s|$)";
string substitution = @"$1";
string input = @"Test test test (test). Test (test test) test test.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}