use strict;
my $str = 'Test test test (test). Test (test test) test test.';
my $regex = qr/(^[^\s(]|\s[^\s(])[^()\s]*(?=\s|$)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";