$re = '/(^[^\s(]|\s[^\s(])[^()\s]*(?=\s|$)/m';
$str = 'Test test test (test). Test (test test) test test.';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;