import re
regex = re.compile(r"(^[^\s(]|\s[^\s(])[^()\s]*(?=\s|$)", flags=re.MULTILINE)
test_str = "Test test test (test). Test (test test) test test."
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)